Subclipse : svn: This client is too old to work with the working copy (format 31)

org.apache.subversion.javahl.ClientException: Unsupported working copy format

This message show up if your are trying to use Subclipse 1.7 client with a Subversion 1.8 working copy or Subclipse 1.6 client with a newer version working copy.
Even if older clients and servers inter-operate transparently with 1.8 servers and clients, when a working copy is upgraded to Subversion 1.8, Subclipse 1.6 and client can no longer be used on it.

You need to get a newer Subversion client but you already upgraded Subclipse

Here is the trick, if Tortoise follow the rule “Version 1.8.X means builts against Subversion 1.8.X”, Subclipse not. Why ?

Subclipse follows an odd/even release numbering convention.
The 1.7.x release stream of Subclipse was built against development builds of Subversion 1.7.
The release of Subversion 1.7.0 started the Subclipse 1.8.X release branch.

So if you tried to upgrade Subclipse with http://subclipse.tigris.org/update_1.8.x that will not work with Subversion 1.8.

What to do

To be simple :

Subclipse 1.4.x works with Subversion 1.5.x features and working copy.
Subclipse 1.6.x works with Subversion 1.6.x features and working copy.
Subclipse 1.8.x works with Subversion 1.7.x features and working copy.
Subclipse 1.10.x works with Subversion 1.8.x features and working copy.

So if you got this error with (format 31), use the check for upgrade option on your Eclipse and add this url
http://subclipse.tigris.org/update_1.10.x

If it’s another error with another working copy error, check the Subclipse version working with your Subversion version, and use the right upgrade url.

Subversion Working Copy Format

Here is a little more explanation about the Subversion working copy format number, from the source code itself.

Source : http://svn.apache.org/repos/asf/subversion/trunk/subversion/libsvn_wc/wc.h

Hope this explain you the difference between TortoiseSVN and Subclipse version numbers and explain the format number in Subversion working copy

6 Responses

  1. smkale says:

    Thanks for the post. I upgraded my subversion client and ran into this issue. Even after deleting and re-importing maven projects, it wasn’t recognizing SVN connection – so no history available, no commit possible. After I upgraded my subclipse to 1.10, now it works!!

  2. George says:

    whew! thanks for summarising this information. Who’d have thought intuitively that you need Subclipse 10 for SVN 8; Subclipse 8 for SVN 7, etc… ?

  3. peterong says:

    Thanks for this valuable info

  4. dwivedi77 says:

    thanks. This helped big time….

  5. 33Sallie says:

    I must say it was hard to find your blog in search results.
    You write interesting content but you should rank your
    blog higher in search engines. If you don’t know how to do it search on youtube:
    how to rank a website Marcel’s way

Leave a Reply

Your email address will not be published. Required fields are marked *